The TeamForge 19.2 release incorporates new features and enhancements that reinforce and expand the unique value of TeamForge. Read more to know what's new!

Release Information

  • Released on: August 1, 2019
  • GA Version: 19.2.443-622

TeamForge Baseline

Here’s the list of what’s new with the TeamForge Baseline feature.

Create New Baselines from Approved Baselines

You can now create a new Baseline from an approved Baseline. In such a case, all but the name and the description fields are auto-filled with data from the source Baseline that’s being cloned. For more information, see Create New Baselines from Approved Baselines.

Create Baseline from Approved Baseline

Support for index.html File in Baseline Packages

Starting from TeamForge 19.2, both index.html and index.pdf files are generated with the Baseline packages. For more information, see Generate and Download Baseline Packages.

The "index.html" file

Export to Excel and Compare Baselines

You can now export the diff of two baselines to Excel, if required.

This Export to Excel feature comes in handy when the number of records in the diff exceeds 10,000, which is the number of records that the Compare Baselines page can handle. While you can choose to use the Compare Baselines page or the “Export to Excel” feature when the diff has less than 10,000 records, you must export to Excel in case the diff exceeds the maximum limit of 10,000 records.

"Export To Excel" button
Error message shown when the diff has more than 10,000 records

A new site-options.conf token, BASELINE_COMPARE_ROOT_FOLDER, has been added to configure the location where the Excel file is generated and stored when you export the diff of two Baselines.

Integrations

Here’s what’s new with TeamForge integrations.

TeamForge—Nexus 2 Integration is No Longer Supported

TeamForge—Nexus 2 integration is no longer supported. If you have TeamForge-Nexus 2 integration, upgrade to Nexus 3 and integrate TeamForge and Nexus 3. For more information, see Installing and Configuring TeamForge-Nexus 3 Integration Plugin.

  • In addition to TeamForge-Jenkins integration and the TeamForge-JIRA integration, TeamForge Webhooks-based Event Broker now supports TeamForge-TestLink integration.
  • TeamForge-TestLink integration using EventQ is no longer supported.
  • A new TeamForge—TestLink integration plugin, collabnet-testlink-1.0.3 is available, which if installed and configured, tracks and synchronizes the requirement and defect tracker artifacts between TeamForge and TestLink via TeamForge Webhooks-based Event Broker.
  • TeamForge 19.2 supports integration only with TestLink 1.9.17 and later. For more information, see Install and Configure the TestLink Integration Plugin.
  • Post upgrade to TeamForge 19.2, you must migrate the TestLink data from the EventQ database to the TeamForge database while setting up the TeamForge—TestLink integartion using the new collabnet-testlink-1.0.3 plugin. For more information, see:

CollabNet TeamForge Maven Deploy Plugin

  • Use the CollabNet TeamForge Maven Deploy Plugin to notify TeamForge (via the TeamForge Webhooks-based Event Broker) about the binary artifact deployment details.

    For more information, see TeamForge Maven Deploy Plugin.

  • Post upgrade to TeamForge 19.2, you must migrate the existing binary artifact data from the EventQ database to the TeamForge database.

    For more information, see Migrate the Binary Artifact Data from EventQ to TeamForge.

  • Binary artifact deployment notifications are no longer sent to TeamForge EventQ.

Trackers—Show Pending and Obsolete Releases

  • A new check box, Show Pending/Obsolete releases, if selected, lets you select one of the pending and obsolete file releases for the Reported in Release and Fixed in Release fields.
  • Selecting this check box, lists the pending and obsolete file releases in the Reported in Release and Fixed in Release fields.
  • The pending and obsolete file releases are greyed out to distinguish them from active file releases.
  • The check box becomes disabled, once you’ve selected a pending or an obsolete file release. To enable it, select an active file release or “None”.

    "Show Pending/Obsolete releases" check box
    Pending and Obsolete File Releases

Documents

The Document Details page has been revamped for better usability (existing command buttons replaced with icons, review tab revamped to have a fresh look and so on).

  • The existing command buttons such as Monitor/Stop Monitoring, Edit/Update, and Users Monitoring are replaced with icons and are grouped on a button bar.

    Document Details page with the new "Monitor", "Edit", and "More (...)" icons
    Command Button Replaced with... Current Location
    Next to the monitor (bell) icon on the button bar.


    Before the edit icon on the button bar. The monitoring icon toggles between grey () color for unmonitored documents and blue () color for monitored documents.
    Added to the "More (...) icon next to the edit icon on the button bar.
  • The Open Document command button is removed from the page, as you can open the document by clicking the document name.

    Document Name with Link
  • The descriptive message you enter when you start a Document review cycle is now shown in the Review Tab (of the Document Details page) for you to have a glance.

    Message for a Document Review Cycle
  • The Review tab UI has been revamped, which include column name changes, new icons to symbolically convey messages, and so on.

    Here’s a table that illustrates the new icons and what they signify.

    Icon Shown in... Signifies...
    STATUS column Review is open/not started
    STATUS column Review is closed/completed
    REVIEWERS column Review from these reviewers is mandatory
    REVIEWERS column Review from these reviewers is optional
    REVIEWERS column Avatars of reviewers
    REVIEWERS column Review completed by the reviewer
    REVIEWERS column Review not completed by the reviewer

File Releases

To mark file releases that are no longer used, a new status, Obsolete, has been added to the Status drop-down list on the Edit Release Page.

The new "Obsolete" status

GitAgile™—Enterprise Version Control

TeamForge—Git Integration 19.2.8-2.15.14 is based on Gerrit version 2.15.

Git Repository Creation Simplified

Creating a Git repository has been simplified with some of the tasks such as setting up the review rules being pushed outside of the repository creation process (out of the Create Repository page).

Here’s a list of changes to the Git repository creation process.

  • Unlike in the past, the review rules can only be configured from the Settings > Policies tab of the repository after the repository has been created.

  • Once a “Pull Request” category Git repository is created, the master branch becomes the default protected branch.

    "master" added as the default protected branch for repositories of type "Pull request"

    Similarly, the master branch becomes the default protected branch for repositories that belong to the user-defined repository category, provided that the category name is prefixed with “Pull Request”. For more information, see Create a User-Defined Repository Category.

    User-defined repository category "pull_request_new" in `TeamForgeGerritMappings.xml` file
    User-defined repository category "pull_request_new" shown as "Pull Request New" in the UI

    Once the repository is created, the master branch becomes a protected branch of the repository by default.

    "master" added as the default protected branch for the user-defined repository category "Pull Request New"

Import Git Repositories from the Code Browser UI

Unlike in the past when you just had the CLI-based import functionality (see How can I import an existing Git repository into Gerrit?), the new import feature, added in TeamForge 19.2, lets you import an external public Git repository into TeamForge, from within the Code Browser UI.

For more information, see Import Git Repository into TeamForge from the Code Browser UI.

Add Files to Git Repository from the Code Browser UI

  • You can now add files to a Git repository from the View tab of the Code Browser UI.
  • You can add only one file at a time. Click the Add a file to repository ( ) icon to add a file to the repository.

    "Add a file to repository" Icon
  • You can either upload an existing file or create a new file from the Add File to Repository pane.
  • The files added (or created) are added to the repository after a direct commit or after a code review.

    "Add Files to Repository" Pane

For more information, see Add Files to Git Repository.

Show Old and New Images in Commit and Code Review Diffs

Old and new images are now shown in commit and code review diffs (for merged requests).

Old and New Images in Commit Diff
Old and New Images in Code Review Diff

No Support for Active-Passive High Availability Setup for Gerrit

Active-Passive High Availability Setup for Gerrit is no longer supported.

History Protection Email Template

The Velocity Templates, used for history protection email notifications, are replaced by Closure Templates (Soy). For more information about the new Closure Templates (Soy), see Gerrit Code Review—Mail Templates.

Bug Fixes in TeamForge—Git Integration 19.2.8-2.15.14

  • The Re-apply logic for mass repository policy settings has been modified to have the settings applied properly.
  • The protected branches, newly added during mass configuration of repository policies, now overwrite the existing protected branches of the repositories.
  • After a tag was deleted from within the Tree view of tags, the tree was not refreshed and the deleted tag was shown. This was fixed.
  • File names were not included in the code search by file path. This was fixed.
  • Double-click behavior was broken in code review diffs. This was fixed.
  • Cleaned up the obsolete gerrit-synch.pid file that was no longer used.

Also see: Bug Fixes in Gerrit 2.15.14.

Configure Your Site’s Settings

The System Tools > Configure Application page.

On sites with SAML or SAML+LDAP authentication, the new site option, ALLOW ‘DIRECT LOGIN’ FOR ALL, comes in handy whenever you want to allow direct login (see Direct Login to TeamForge) for all the users regardless of the “Local User” setting (see Enable Local User).

If you enable the ALLOW ‘DIRECT LOGIN’ FOR ALL site option, users without a TeamForge account that try to login using the direct login URL are taken to the Create TeamForge Account page for account creation.

ALLOW DIRECT LOGIN FOR ALL site option

Install/Upgrade

  • SSL is enabled by default in TeamForge 19.2 and later. If you are upgrading to TeamForge 19.2 or later, you must remove the SSL=on site options token from the site-options.conffile, failing which the teamforge provision command will not be successful. The SSL token is no longer supported, and if used, would error out when you provision TeamForge.
  • OpenJDK (version 9.0.4) replaces Oracle JRE 9 in TeamForge 19.2 and later. It is recommended to remove the JAVA_HOME token, if added to your site-options.conf file. TeamForge uses the default JAVA_HOME which is set to the OpenJDK path.

    TeamForge 16.10 and earlier versions use Oracle JDK. As TeamForge 19.2 uses OpenJDK, the TeamForge 19.2 installer checks if Oracle JDK is present when you upgrade to TeamForge 19.2 or later, and if found, would error out when you provision TeamForge. You must uninstall Oracle JDK and proceed.

    Run the following command to uninstall Oracle JDK:

    rpm -e jdk1.8.0_74-1.8.0_74-fcs.x86_64
    
Tags for this page: getting_started